How to Integrate Mannasim with NS-2.35

The Mannasim framework is a third party Wireless Sensor Network Simulation environment based on the Network Simulator (NS). In this DIY we will learn how we can integrate the Mannasim with the NS-2.35. You can learn more about the Mannasim here.


Step 1: Prerequisites

1. First of all we need a working NS-2.35, installed on Ubuntu-12.04/13.10/14.04. You can find the DIY on installation of NS-2.35 in Ubuntu-12.04 here and in Ubuntu-13.10/14.04 here.

2. Second, we need the Mannasim patch files for NS-2.35, which can be downloaded from here. I assume you have downloaded the "mannasim-NS-2.35.tar.gz" in '/home/user_name/Documents' and have your NS-2.35installed in '/home/user_name/Documents/ns-allinone-2.35/'.


Step 2: Integrating Mannasim with NS-2.35

1. Extract the downloaded Mannasim patch either using the right click context menu "Extract here" or using the following command from a terminal:

1 tar -xvzf /home/user_name/Documents/ns-allinone-2.35.tar.gz

2. Go to the directory where you have extracted the package, in our case its '/home/user_name/Documents'. Now move the extracted "mannasim" folder inside the already installed "ns-allinone-2.35/ns-2.35".

3. Inside the mannasim folder there will be a "ns-modified-folder" that contains set of files to be pasted to different locations (image 1).

Image 1. ns-modified-files

Copy these files and paste (replace) them in following locations:

File Copy to
udp.cc ns-allinone-2.35/ns-2.35/apps/
ns-process.h ns-allinone-2.35/ns-2.35/common/
packet.cc ns-allinone-2.35/ns-2.35/common/
packet.h ns-allinone-2.35/ns-2.35/common/
ns-default.tcl ns-allinone-2.35/ns-2.35/tcl/lib/
ns-lib.tcl ns-allinone-2.35/ns-2.35/tcl/lib/
Makefile.in ns-allinone-2.35/ns-2.35/

4. Once everything is done, go to the terminal and move to the "ns-allinone-2.35/ns-2.35" directory. Now run the following commands one by one:

1 ./configure
2 make clean
3 make


Step 3: Test the Integration

To test Mannasim installation two simulation scripts are provided below. The first one simulates a flat network of homogeneous sensors and the second a hierarchical network composed of two different classes of sensor nodes.

Click on the links to get the TCL code:
1. Flat homogeneous network TCL Script.
2. Hierarchical heterogeneous network TCL Script.

You can run these files using:

1 ns mannasim-rede-plana.tcl
2 ns mannasim-rede-hierarquica.tcl

You should get output as shown in image 2.

Image 2. Testing the Integration.

You have successfully integrated the Mannasim with NS-2.35. Congratulations !! Have fun !

— * — * — * — * —

Source

63 comments:

  1. configure: error: Installation of tcl seems incomplete or can't be found automatically.
    Please correct the problem by telling configure where tcl is
    using the argument --with-tcl=/path/to/package
    (perhaps after installing it),
    or the package is not required, disable it with --with-tcl=no.
    sunil@sunil-Lenovo-B560:~/ns-allinone-2.35/ns-2.35$
    plz help me iam getting this error

    ReplyDelete
    Replies
    1. Hello... I think there's some problem with ur tcl installation. Pls check if it is installed correctly. You can use the following command (without quotes) to check the installation

      "echo puts $tcl_version;exit 0 | tclsh"

      also make sure that ur ns is installed correctly. For installing the mannasim, it is required to that ns must be installed correctly. Hope it helps !

      Goodluck.

      Delete
  2. Hello
    while mannasim installation i am getting error at ./configure command and the error is:

    configure: error: Installation of tcl seems incomplete or can't be found automatically.
    Please correct the problem by telling configure where tcl is
    using the argument --with-tcl=/path/to/package
    (perhaps after installing it),
    or the package is not required, disable it with --with-tcl=no.

    Please provide solution for this.

    ReplyDelete
    Replies
    1. Please make sure that you have set the environment variables correctly while installing the ns. May be you should take a look at the following link regarding setting the variables correctly.

      http://installwithme.blogspot.in/2014/05/how-to-install-ns-2.35-in-ubuntu-13.10-or-14.04.html

      Delete
    2. sir i had set environment variable properly but that error is still there.

      Delete
    3. Ok... Are you able to run the ns without integrating the mannasim ?

      Delete
    4. The problem seems to occur when you have two versions of tcl installed in your system, run the following command to check for the versions of the tcl "echo puts $tcl_version;exit 0 | tclsh" (without quotes).

      Also you can try "./configure --with-tcl-ver=8.5" instead of "./configure" (without quotes). Let me know the results. Goodluck :)

      Delete
    5. thank you sir
      this command "./configure --with-tcl-ver=8.5" works.
      mannasim is successfully installed.
      again thank you sir

      Delete
    6. Hi, I did the change to ./configure --with-tcl-ver=8.5,
      But when I ran the make command I got the following error:
      the isn't any rule to build «mannasim/access point app.o» need to <>

      Delete
    7. Thank you Sir,
      It does work like a charm. Lucky I found this blog.

      Delete
    8. "./configure --with-tcl-ver=8.5" works. thank you very much.

      Delete
    9. Hello Sir,
      When I run the command "./configure" it shows me this error
      " configure: error: Installation of tcl seems incomplete or can't be found automatically.
      Please correct the problem by telling configure where tcl is
      using the argument --with-tcl=/path/to/package
      (perhaps after installing it),
      or the package is not required, disable it with --with-tcl=no."
      So I changed as you said to "./configure --with-tcl-ver=8.5" and it works fine but when I run "make" it shows me this error "make: *** No rule to make target `mannasim/accessPointApp.o', needed by `ns'. Stop" SO can you help me, Sir, and thanks in advance

      Delete
  3. Hello.....
    While we run tcl scripts in Mannasim , Nam do not open.
    Why does the Nam not open ?

    Plz provide solution for this.

    ReplyDelete
    Replies
    1. Please ensure that your tcl file have the exec nam command in it. The basic syntax is 'exec nam filename.nam' without it nam won't run on its own.

      Delete
  4. Hello sir , I have simulated LEACH protocol in mannasim using script generator tool but where it shows the actual network i.e. cluster heads,nodes,sink node as NAM doesn't show anything. What can be the problem sir? Plz Help..................

    ReplyDelete
    Replies
    1. Hello... First of all try to run a simple tcl script if it runs fine and NAM also shows all the things then your NAM is fine. Next you have to look at your LEACH tcl file for any bugs.

      Delete
  5. hi sir, i need your help.
    I have successfully installed ns2.35 in ubuntu and have also installed mannasim in it. i want to simulate Leach protocol. kindly suggest me how to simulate and what can be the possible parameters in script generator Tools for simulation.
    Thanku

    ReplyDelete
    Replies
    1. Hello...
      Please refer the following link

      http://abdusyarif.wordpress.com/2012/05/16/installing-running-leach-ns-2-34-step-by-step/

      Goodluck !

      Delete
    2. Also refer this too

      https://drive.google.com/file/d/0B6h9t5Gy7FoQS2xiTkp4VEtTaHc/view?usp=sharing

      Delete
  6. Hello
    I have successfully installed Mannasim framework on ubuntu 14.04 and run LEACH code. Now i want to modify the LEACH code and 
    1. I want to know where the Cluster Head and sensor nodes creation takes place
    2. Is re-Clustering performed, if YES, where(which file) it takes place
    3. The communication between different node including Cluster Heads and Access Point(Sinks) is hop-by-hop or not?

    Please help me in resolving these issues.

    ReplyDelete
    Replies
    1. Hello...
      Kindly refer to this pdf for your queries

      https://drive.google.com/file/d/0B6h9t5Gy7FoQS2xiTkp4VEtTaHc/view?usp=sharing

      Hope it helps !

      Delete
    2. Hello Reenkamal Gill,
      I have successfully run leach protocol in ns-2.35 on ubuntu 14.04.
      Now I want to simulated protocol by NAM application, but I don't find the nam file in ns-2.35 directory.
      Can you show me where the nam file is.
      Thanks.

      Delete
  7. hello sir
    kindly please tell me how to analyze the trace file of mannasim genertaed LEACH.
    e.g.
    r -t 0.053538872 -Hs 1 -Hd -2 -Ni 1 -Nx 64.52 -Ny 10.68 -Nz 0.00 -Ne 9.999998 -Nl MAC -Nw --- -Ma 0 -Md 3000000 -Ms ffff0008 -Mt 0 -Is 3.0 -Id -1.0 -It tcp -Il 1 -If 0 -Ii 0 -Iv 32 -Pn tcp -Ps 0 -Pa 0 -Pf 1 -Po 0

    ReplyDelete
  8. i got this error while simulating leach in ns2.35 with mannasim in ubuntu

    error is: Warning! No Cluster Head ADVs were heard by 3
    Node 3 sending 100 data to BS at time 1.632786
    Error: Meta size 2844 too large (max = 1000).

    ReplyDelete
    Replies
    1. Maybe you should adjust the parameters to keep the value in bounds.

      Delete
  9. hello, I have followed the above mentioned procedure and have caught some errors
    can u help me in solving these?
    warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
    INITIALIZE THE LIST xListHead
    invalid command name "EnergyModel/Battery"
    while executing
    "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2"
    invoked from within
    "catch "$className create $o $args" msg"
    invoked from within
    "if [catch "$className create $o $args" msg] {
    if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
    delete $o
    return ""
    }
    global errorInfo
    error "class $..."
    (procedure "new" line 3)
    invoked from within
    "new $energyModel_ $node $initialEnergy_ $l1 $l2"
    invoked from within
    "if [info exists energyModel_] {
    if [info exists level1_] {
    set l1 $level1_
    } else {
    set l1 0.5
    }
    if [info exists level2_] {
    set l2 $level2_
    } else {..."
    (procedure "_o3" line 115)
    (Simulator create-wireless-node line 115)
    invoked from within
    "_o3 create-wireless-node"
    ("eval" body line 1)
    invoked from within
    "eval $self create-wireless-node $args"
    (procedure "_o3" line 23)
    (Simulator node line 23)
    invoked from within
    "$ns_ node"
    (procedure "create_sink" line 8)
    invoked from within
    "create_sink"
    (file "mannasim-rede-plana.tcl" line 350)

    ReplyDelete
    Replies
    1. Hello, don't worry about the warning regarding the channel it won't cause a problem You can ignore it and if you still want to correct it then please follow the way shown in 'tcl/ex/wireless-mitf.tcl' file.

      As for the "EnergyModel/Battery" it means that you are using an executable 'ns' with no mannasim.
      i.e. you are using the wrong 'ns'. Or if you have only one file by name 'ns' then No mannasim was compiled into 'ns'. That generally happens when you have a failed build.

      Delete
    2. i used "./ns mannasim-rede-plana.tcl" rather then simple "ns mannasim-rede-plana.tcl" and it worked..!!!

      Delete
    3. I have tried using ./ns mannasim-rede-plana.tcl
      but it is showing error
      panam@ubuntu:~/Desktop$ ./ns mannasim-rede-plana.tcl
      bash: ./ns: No such file or directory
      but my ns is working fine.
      so what should I do?

      Delete
    4. When u run "ns mannasim-rede-plana.tcl" what is it showing ?

      Delete
    5. Sir, on running ns mannasim-rede-plana.tcl i am getting this error...

      num_nodes is set 12
      warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
      INITIALIZE THE LIST xListHead
      invalid command name "EnergyModel/Battery"
      while executing
      "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2"
      invoked from within
      "catch "$className create $o $args" msg"
      invoked from within
      "if [catch "$className create $o $args" msg] {
      if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
      delete $o
      return ""
      }
      global errorInfo
      error "class $..."
      (procedure "new" line 3)
      invoked from within
      "new $energyModel_ $node $initialEnergy_ $l1 $l2"
      invoked from within
      "if [info exists energyModel_] {
      if [info exists level1_] {
      set l1 $level1_
      } else {
      set l1 0.5
      }
      if [info exists level2_] {
      set l2 $level2_
      } else {..."
      (procedure "_o3" line 115)
      (Simulator create-wireless-node line 115)
      invoked from within
      "_o3 create-wireless-node"
      ("eval" body line 1)
      invoked from within
      "eval $self create-wireless-node $args"
      (procedure "_o3" line 23)
      (Simulator node line 23)
      invoked from within
      "$ns_ node"
      (procedure "create_sink" line 8)
      invoked from within
      "create_sink"
      (file "mannasim-rede-plana.tcl" line 350)

      Doesn't even work with ./ns

      Delete
    6. Try this, ./ns mannasim-rede-plana.tcl
      use the current directory.Mine is working.

      Delete
  10. hello sir, i installed mannasim patch in ns-2.35 on Ubuntu 13.04 by above steps. the following error is encountered.
    pl. help urgently. will be thankful.''

    error:
    linkstate/ls.h:137:20: note: declarations in dependent base ‘std::map, std::allocator > >’ are not found by unqualified lookup
    linkstate/ls.h:137:20: note: use ‘this->erase’ instead
    make: *** [linkstate/ls.o] Error 1

    ReplyDelete
    Replies
    1. Hello, Seems like you have some problem with your ns installation. Did you installed it successfully ? Plz follow this link for the ns installation first

      http://installwithme.blogspot.in/2014/05/how-to-install-ns-2.35-in-ubuntu-13.10-or-14.04.html

      Delete
    2. this problem has been resolved. u have given two files in the last to check whether mannasim is working properly or not. i tried one of them mannasim-rede-plana.tcl. downloaded and saved on desktop then executed on editor. but it is not showing the contents in the same way that is given.
      it is showing like this
      amita@amita-Lenovo-G580:~/Desktop$ ns mannasim-rede-plana.tcl
      num_nodes is set 12
      warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
      INITIALIZE THE LIST xListHead
      invalid command name "EnergyModel/Battery"
      while executing
      "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2"
      invoked from within
      "catch "$className create $o $args" msg"
      invoked from within
      "if [catch "$className create $o $args" msg] {
      if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
      delete $o
      return ""
      }
      global errorInfo
      error "class $..."
      (procedure "new" line 3)
      invoked from within
      "new $energyModel_ $node $initialEnergy_ $l1 $l2"
      invoked from within
      "if [info exists energyModel_] {
      if [info exists level1_] {
      set l1 $level1_
      } else {
      set l1 0.5
      }
      if [info exists level2_] {
      set l2 $level2_
      } else {..."
      (procedure "_o3" line 115)
      (Simulator create-wireless-node line 115)
      invoked from within
      "_o3 create-wireless-node"
      ("eval" body line 1)
      invoked from within
      "eval $self create-wireless-node $args"
      (procedure "_o3" line 23)
      (Simulator node line 23)
      invoked from within
      "$ns_ node"
      (procedure "create_sink" line 8)
      invoked from within
      "create_sink"
      (file "mannasim-rede-plana.tcl" line 350)
      amita@amita-Lenovo-G580:~/Desktop$ ns mannasim-rede-plana.tcl
      num_nodes is set 12
      warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
      INITIALIZE THE LIST xListHead
      invalid command name "EnergyModel/Battery"
      while executing
      "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2"
      invoked from within
      "catch "$className create $o $args" msg"
      invoked from within
      "if [catch "$className create $o $args" msg] {
      if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
      delete $o
      return ""
      }
      global errorInfo
      error "class $..."
      (procedure "new" line 3)
      invoked from within
      "new $energyModel_ $node $initialEnergy_ $l1 $l2"
      invoked from within
      "if [info exists energyModel_] {
      if [info exists level1_] {
      set l1 $level1_
      } else {
      set l1 0.5
      }
      if [info exists level2_] {
      set l2 $level2_
      } else {..."
      (procedure "_o3" line 115)
      (Simulator create-wireless-node line 115)
      invoked from within
      "_o3 create-wireless-node"
      ("eval" body line 1)
      invoked from within
      "eval $self create-wireless-node $args"
      (procedure "_o3" line 23)
      (Simulator node line 23)
      invoked from within
      "$ns_ node"
      (procedure "create_sink" line 8)
      invoked from within
      "create_sink"
      (file "mannasim-rede-plana.tcl" line 350)
      amita@amita-Lenovo-G580:~/Desktop$ ns mannasim-rede-plana.tcl

      Delete
    3. Pls refer the comment and reply to Mr. Kartik Trivedi (just above the your comment).

      Delete
  11. i am getting permission denied while running for configuration
    gaurav@gaurav-Compaq-Presario-C700-Notebook-PC:~/gaurav/ns-allinone-2.35/ns-2.35$ ./configure./configure: line 2097: config.log: Permission denied
    ./configure: line 2107: config.log: Permission denied

    ReplyDelete
    Replies
    1. Did you tried to run "sudo ./configure". Also are you the admin of the system ?

      Delete
  12. sir plz help me..........
    when i do above procedure to run mannasim. no problem until make clean
    but i give make
    it show error that dsdv/dsdv.cc 164:14 error: class rtable_ent has no member named trigger_event
    plz give me a solution

    ReplyDelete
  13. Hello Dhyan Singh,
    I have successfully installed Mannasim framework on ubuntu 14.04 but I don't know how can I run LEACH code.
    Please help me.
    Thanks.

    ReplyDelete
    Replies
    1. Hello
      You may use the following link for detailed instructions: https://drive.google.com/file/d/0B6h9t5Gy7FoQS2xiTkp4VEtTaHc/view?usp=sharing

      P.S.: I have not used it I just hope that it wil help.

      Delete
    2. hey.. did you get the leach code. please mail it to me at shruti.karva@gmail.com

      Delete
  14. Dear Dhyan Singh, Sir,

    First thank you for the amazing tutorials.

    I have followed all your instruction on how to install ns2 and mannasim.
    It appears the installation process went fine but unfortunately consistent with mr. Kartik Trivadi's error message I get " ns mannasim-rede-plana.tcl
    num_nodes is set 12
    warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
    INITIALIZE THE LIST xListHead
    invalid command name "EnergyModel/Battery"
    while executing
    "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2" ....

    And when I tried mr Trivadi's "./" option, I got the following feedback:

    "paulchiedo@paulchiedo-virtual-machine:~$ ./ns mannasim-rede-plana.tcl
    bash: ./ns: No such file or directory"

    I would really appreciate it if you could point out what the problem might be..

    Similarly, I have tried to run Mannasim Script Generator(MSG) thus:

    1. "paulchiedo@paulchiedo-virtual-machine:~$ -> ./msg-linux.sh
    -: command not found"

    2. "paulchiedo@paulchiedo-virtual-machine:~/Documents/ns-allinone-2.35/ns-2.35$ $-> ./msg-linux.sh
    himBH: command not found"


    I keep getting the feeback "command not found" so I am wondering if
    MSG should be installed seperately or does it come with the installation of mannasim?

    If it does come with the mannasim installation which command and from which directory can I run it

    Thank you in advance!

    ReplyDelete
  15. Hello Sir ,

    Following is the error while comping Flat homogeneous network TCL Script.
    Meanwhile NS2.35 with Mannasim has been installed successfully.

    num_nodes is set 12
    warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
    INITIALIZE THE LIST xListHead
    warning: no class variable Application/AccessPointApp::destination_id_

    see tcl-object.tcl in tclcl for info about this warning.

    warning: no class variable Application/AccessPointApp::request_type_

    warning: no class variable Application/AccessPointApp::node_id_

    warning: no class variable Application/AccessPointApp::diretorio

    warning: no class variable Application/SensorBaseApp/CommonNodeApp::disseminating_type_

    see tcl-object.tcl in tclcl for info about this warning.

    warning: no class variable Application/SensorBaseApp/CommonNodeApp::disseminating_interval_

    warning: no class variable Application/SensorBaseApp/CommonNodeApp::destination_id_


    (_o60 cmd line 1)
    invoked from within
    "_o60 cmd add-app _o80"
    invoked from within
    "catch "$self cmd $args" ret"
    invoked from within
    "if [catch "$self cmd $args" ret] {
    set cls [$self info class]
    global errorInfo
    set savedInfo $errorInfo
    error "error when calling class $cls: $args" $..."
    (procedure "_o60" line 2)
    (SplitObject unknown line 2)
    invoked from within
    "$node_($contador_nodos) add-app $app_($contador_nodos)"
    (procedure "create_common_node" line 41)
    invoked from within
    "create_common_node"
    ("for" body line 2)
    invoked from within
    "for {set i 0} {$i < $val(n_common)} {incr i} {
    create_common_node
    }"
    (file "mannasim-rede-plana.tcl" line 357)

    ReplyDelete
  16. hello sir.. Plz help
    i installed mannasim as shown above and tried to verify with the "ns mannasim-rede-plana.tcl " file but got an error as follows :
    ns:
    [code omitted because of length]
    : invalid command name "DataGenerator/TemperatureDataGenerator"
    while executing
    "DataGenerator/TemperatureDataGenerator set sensing_interval_ 0.0"

    ReplyDelete
  17. hello sir can u plz help me with LEACH protocol tcl script....

    ReplyDelete
  18. i had gone through all the above steps. when i was about to test the example I am getting this error

    vinay@vinay-VirtualBox:~$ ns mannasim-rede-plana.tcl
    ns:
    [code omitted because of length]
    : invalid command name "DataGenerator/TemperatureDataGenerator"
    while executing
    "DataGenerator/TemperatureDataGenerator set sensing_interval_ 0.0"

    ReplyDelete
    Replies
    1. I am also getting same error.. have u find the solutn??

      Delete
  19. Hello sir, I have followed all the steps give above..but when i tried to run the files mannasim-rede-plana.tcl and mannasim-rede-hierarquica.tcl, i got an error as follows

    ns:
    [code omitted because of length]
    : invalid command name "DataGenerator/TemperatureDataGenerator"
    while executing
    "DataGenerator/TemperatureDataGenerator set sensing_interval_ 0.0"

    Please help me out..Thank you..

    ReplyDelete
  20. hi
    I install ns2.34 correctly.
    but after install mannasim with ns doesnt work.
    erorr is:
    ns:
    [code omitted because of length]
    : invalid command name "DataGenerator/TemperatureDataGenerator"
    while executing
    "DataGenerator/TemperatureDataGenerator set sensing_interval_ 0.0"
    while executing
    What is the problem?

    ReplyDelete
  21. I have installed ns2 and integrated it with mannasim. Now I wish to simulate TORA protocol. What are the steps to be followed to simulate these?

    http://wpage.unina.it/marcello.caleffi/ns2/tora.cc and

    http://wpage.unina.it/marcello.caleffi/ns2/tora.h

    Can you please help me.

    ReplyDelete
  22. sir i tried the sample scripts given on the website. i am getting the following error
    invalid command name "EnergyModel/Battery"
    while executing
    "EnergyModel/Battery create _o33 _o15 100.0 0.5 0.2"
    invoked from within
    "catch "$className create $o $args" msg"
    invoked from within
    "if [catch "$className create $o $args" msg] {
    if [string match "__FAILED_SHADOW_OBJECT_" $msg] {
    delete $o

    ReplyDelete
  23. i got the same error as by mr kartik..and i tried ./ns instead of ns..but still the error is sam..can u plz provide me the solution..

    ReplyDelete
  24. How do I rectify this? ....

    anirban@anirban:~/Documents/ns-allinone-2.35/ns-2.35$ make
    rm -f gen/version.c
    /home/anirban/Documents/ns-allinone-2.35/bin/tclsh8.5 bin/string2c.tcl version_string < VERSION > gen/version.c
    /bin/sh: 1: cannot create gen/version.c: Permission denied
    Makefile:560: recipe for target 'gen/version.c' failed
    make: *** [gen/version.c] Error 2
    anirban@anirban:~/Documents/ns-allinone-2.35/ns-2.35$

    ReplyDelete
  25. I am getting the following erroe when i run the mannasim-rede-plana.tcl. Please help me`
    num_nodes is set 12
    warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
    INITIALIZE THE LIST xListHead

    (_o60 cmd line 1)
    invoked from within
    "_o60 cmd add-app _o80"
    invoked from within
    "catch "$self cmd $args" ret"
    invoked from within
    "if [catch "$self cmd $args" ret] {
    set cls [$self info class]
    global errorInfo
    set savedInfo $errorInfo
    error "error when calling class $cls: $args" $..."
    (procedure "_o60" line 2)
    (SplitObject unknown line 2)
    invoked from within
    "$node_($contador_nodos) add-app $app_($contador_nodos)"
    (procedure "create_common_node" line 41)
    invoked from within
    "create_common_node"
    ("for" body line 2)
    invoked from within
    "for {set i 0} {$i < $val(n_common)} {incr i} {
    create_common_node
    }"
    (file "mannasim-rede-plana.tcl" line 357)

    ReplyDelete
  26. Sir,
    I want to install Mannasim 2.35 for LEACH protocol on NS2.35 installed on RedLhat Enterprise inux 5.2.
    I have installed YUM on RHEL 5.2 then NS2.35 all in one it is working properly,
    Can i install Mannasim on this envoirnment.

    ReplyDelete
  27. ikram2403@vikram2403-Inspiron-3541:~/ns2/programs$ ns droptailwired.tcl
    application-specific initialization failed: Can't find a usable init.tcl in the following directories:
    /home/vikram2403/vikram/ns-allinone-2.35/lib/tcl8.5 /usr/local/lib/tcl8.5 /usr/lib/tcl8.5 /usr/local/library /usr/library /usr/tcl8.5.10/library /tcl8.5.10/library

    what is the mistake plz help me

    ReplyDelete
  28. hello sir, i installed mannasim patch in ns-2.35 on Ubuntu 14.04 . the following error is encountered.
    pl. help me.thank you''

    checking for a BSD-compatible install... /usr/bin/install -c
    configure: creating ./config.status
    chmod: changing permissions of './config.status': Operation not permitted
    configure: error: write failure creating ./config.status

    ReplyDelete
  29. Hello Sir, what is the next step after successfully integrate mannasim in ns-2.35 for the simulation of LEACH protocol with the help of NAM file??

    ReplyDelete
  30. thanks Dear Dhyan , it worked like a charm with your kind post. God bless you, Regards,

    ReplyDelete
  31. I have successfully installed the NS2.35 in Ubuntu 14.04 and also successfully patched mannasim framework for sensor network simulation. I could easily run the sample codes given in the website but the scriptGeneratorTool is not working. To run the scriptGeneratorTool i did the following:
    1. Copied the scriptGeneratorTool folder from the unzipped manasim folder to the mannasim folder located inside ns-2.35 folder since that folder was removed during patch process.
    2. then went inside the scriptGeneratorTool folder and tried to execute the tool by typing "./msg-linux.sh" but encountered the following error:

    Exception in thread "main" java.lang.NoClassDefFoundError: gui/MainFrame
    Caused by: java.lang.ClassNotFoundException: gui.MainFrame
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
    Could not find the main class: gui.MainFrame. Program will exit.
    vinitpradhan18@vsp18:~/ns-allinone-2.35/ns-2.35/mannasim/scriptGeneratorTool$ ./msg-linux.sh
    Exception in thread "main" java.lang.NoClassDefFoundError: gui/MainFrame
    Caused by: java.lang.ClassNotFoundException: gui.MainFrame
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
    Could not find the main class: gui.MainFrame. Program will exit.

    Please Help...

    ReplyDelete